CVE-2025-9958 Insertion of Sensitive Information Into Sent Data in GitLab
Guest users can access sensitive information stored in virtual registry configurations, requiring an upgrade to GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-9958?
CVE-2025-9958 is a high-severity vulnerability in Gitlab Gitlab, published on 26 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions from 14.10 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1, that could have allowed Guest users to access sensitive information stored in virtual registry configurations.
Weakness: CWE-201
Which versions are affected by CVE-2025-9958?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.10.0 | 18.2.7, 18.3.3, 18.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-9958?
Upgrade gitlab to a fixed version for your release line: 18.2.7, 18.3.3 or 18.4.1.
Is CVE-2025-9958 being exploited?
There is no known exploitation of CVE-2025-9958 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-9958, GHSA-mq5h-8f38-3xwp.