# CVE-2026-0540: DOMPurify XSS via Missing Rawtext Elements in SAFE_FOR_XML

> Attackers can execute arbitrary JavaScript by bypassing DOMPurify sanitization via missing rawtext elements in SAFE_FOR_XML mode.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Mar 2026
- **Updated:** 25 Mar 2026
- **Also known as:** CLEANSTART-2026-LL84916, CLEANSTART-2026-PI18727, DEBIAN-CVE-2026-0540, ECHO-c8de-3322-06e5, GHSA-v2wj-7wpq-c8vv, MINI-cj56-cg85-3fvm, MINI-cm65-jgp6-g8fj, MINI-h925-3f3w-w559, MINI-jhm9-788c-cfrw, MINI-phrg-f3gv-fc6r, MINI-q8mp-gmrj-9mrh, MINI-qrmr-8vf3-mh8f, MINI-rx4r-892w-9phv, MINI-vcq4-65w6-mqmv, ROOT-APP-NPM-CVE-2026-0540, UBUNTU-CVE-2026-0540, openSUSE-SU-2026:10599-1

## What is CVE-2026-0540?

CVE-2026-0540 is a medium-severity cross-site scripting vulnerability in cure53 DOMPurify, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

DOMPurify 3.1.3 through 3.3.1 and 2.5.3 through 2.5.8, fixed in commit 2726c74, contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting five missing rawtext elements (noscript, xmp, noembed, noframes, iframe) in the SAFE_FOR_XML regex. Attackers can include payloads like </noscript><img src=x onerror=alert(1)> in attribute values to execute JavaScript when sanitized output is placed inside these unprotected rawtext contexts.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-0540?

4 open source packages ship an affected version, including dompurify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompurify` | npm | From 2.5.3 | 2.5.9 |
| `dompurify` | npm | From 2.5.3 | 2.5.9 |
| `dompurify` | npm | From 3.1.3 | 3.3.2 |
| `dompurify` | npm | From 3.1.3 | 3.3.2 |
| `cacti` | openSUSE:Tumbleweed | All versions | 1.2.30+git306.82d5aef5-1.1 |

Products: Cure53 Dompurify.

## How do I fix CVE-2026-0540?

Upgrade dompurify to a fixed version for your release line: 2.5.9 or 3.3.2.

## Is CVE-2026-0540 being exploited?

There is no known exploitation of CVE-2026-0540 in the wild and no public exploit code.

## Other vulnerabilities in cure53 DOMPurify

- [CVE-2024-47875](https://insights.sbomify.com/CVE-2024-47875/): DOMPurify nesting-based mXSS (critical 10.0)
- [CVE-2024-48910](https://insights.sbomify.com/CVE-2024-48910/): DOMPurify vulnerable to tampering by prototype polution (critical 9.1)
- [CVE-2026-47423](https://insights.sbomify.com/CVE-2026-47423/): DOMPurify XSS via `selectedcontent` re-clone (high 8.2)
- [CVE-2024-45801](https://insights.sbomify.com/CVE-2024-45801/): Tampering by prototype polution in DOMPurify (high 7.3)
- [CVE-2026-49978](https://insights.sbomify.com/CVE-2026-49978/): DOMPurify IN_PLACE Sanitization Bypass via Attached Shadow Root Inside <template>.content (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0540 and fix it if it is affected.

What it is: CVE-2026-0540 is a medium-severity cross-site scripting vulnerability in cure53 DOMPurify, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-0540 in the wild and no public exploit code.

Affected packages and fixed versions:
- dompurify (npm): affected from 2.5.3; fixed in 2.5.9
- dompurify (npm): affected from 2.5.3; fixed in 2.5.9
- dompurify (npm): affected from 3.1.3; fixed in 3.3.2
- dompurify (npm): affected from 3.1.3; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0540/ (Markdown: https://insights.sbomify.com/CVE-2026-0540/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0540
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0540
- OSV: https://osv.dev/vulnerability/CVE-2026-0540

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0540/
Summaries are generated and may contain mistakes; the official description above is the record.
