# CVE-2026-0558: Unauthenticated File Upload in parisneo/lollms

> Unauthenticated users can upload files via an unprotected endpoint, causing resource exhaustion and potential information disclosure.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** GHSA-4574-jvgw-55gr, PYSEC-2026-2198

## What is CVE-2026-0558?

CVE-2026-0558 is a high-severity missing authorization vulnerability in parisneo/lollms, published on 29 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in parisneo/lollms, up to and including version 2.2.0, allows unauthenticated users to upload and process files through the `/api/files/extract-text` endpoint. This endpoint does not enforce authentication, unlike other file-related endpoints, and lacks the `Depends(get_current_active_user)` dependency. This issue can lead to denial of service (DoS) through resource exhaustion, information disclosure, and violation of the application's documented security policies.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-0558?

1 open source package ship an affected version, including lollms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions | 2.1.1 |

Products: Lollms Lollms.

## How do I fix CVE-2026-0558?

Upgrade lollms to 2.1.1 or later.

## Is CVE-2026-0558 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0558 exists.

Public exploit code:

- LolLMS <= 2.2.0 - Unauthenticated File Upload (nuclei): http/cves/2026/CVE-2026-0558.yaml

## Other vulnerabilities in parisneo/lollms

- [CVE-2026-1114](https://insights.sbomify.com/CVE-2026-1114/): Improper Access Control via Weak JWT Token in parisneo/lollms (critical 9.8)
- [CVE-2024-3429](https://insights.sbomify.com/CVE-2024-3429/): Path Traversal in parisneo/lollms (critical 9.8)
- [CVE-2026-1115](https://insights.sbomify.com/CVE-2026-1115/): Stored XSS in parisneo/lollms (critical 9.6)
- [CVE-2026-12228](https://insights.sbomify.com/CVE-2026-12228/): Stored XSS in Direct Messages via Prompt Sharing in parisneo/lollms (high 8.7)
- [CVE-2026-0562](https://insights.sbomify.com/CVE-2026-0562/): Insecure Direct Object Reference (IDOR) in parisneo/lollms (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0558 and fix it if it is affected.

What it is: CVE-2026-0558 is a high-severity missing authorization vulnerability in parisneo/lollms, published on 29 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0558 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0558/ (Markdown: https://insights.sbomify.com/CVE-2026-0558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0558
- OSV: https://osv.dev/vulnerability/CVE-2026-0558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0558/
Summaries are generated and may contain mistakes; the official description above is the record.
