# CVE-2026-0560: Server-Side Request Forgery (SSRF) in parisneo/lollms

> Attackers can exploit an SSRF vulnerability in the file export endpoint to access internal services and potentially execute remote code.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** GHSA-rqmp-494m-8qgf, PYSEC-2026-2199

## What is CVE-2026-0560?

CVE-2026-0560 is a high-severity server-side request forgery vulnerability in parisneo/lollms, published on 29 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability exists in parisneo/lollms versions prior to 2.2.0, specifically in the `/api/files/export-content` endpoint. The `_download_image_to_temp()` function in `backend/routers/files.py` fails to validate user-controlled URLs, allowing attackers to make arbitrary HTTP requests to internal services and cloud metadata endpoints. This vulnerability can lead to internal network access, cloud metadata access, information disclosure, port scanning, and potentially remote code execution.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-0560?

1 open source package ship an affected version, including lollms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions | 2.1.1 |

Products: Lollms Lollms.

## How do I fix CVE-2026-0560?

Upgrade lollms to 2.1.1 or later.

## Is CVE-2026-0560 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0560 exists.

Public exploit code:

- LolLMS < 2.2.0 - Server-Side Request Forgery (nuclei): http/cves/2026/CVE-2026-0560.yaml

## Other vulnerabilities in parisneo/lollms

- [CVE-2026-1114](https://insights.sbomify.com/CVE-2026-1114/): Improper Access Control via Weak JWT Token in parisneo/lollms (critical 9.8)
- [CVE-2024-3429](https://insights.sbomify.com/CVE-2024-3429/): Path Traversal in parisneo/lollms (critical 9.8)
- [CVE-2026-1115](https://insights.sbomify.com/CVE-2026-1115/): Stored XSS in parisneo/lollms (critical 9.6)
- [CVE-2026-12228](https://insights.sbomify.com/CVE-2026-12228/): Stored XSS in Direct Messages via Prompt Sharing in parisneo/lollms (high 8.7)
- [CVE-2026-0562](https://insights.sbomify.com/CVE-2026-0562/): Insecure Direct Object Reference (IDOR) in parisneo/lollms (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0560 and fix it if it is affected.

What it is: CVE-2026-0560 is a high-severity server-side request forgery vulnerability in parisneo/lollms, published on 29 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0560 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0560/ (Markdown: https://insights.sbomify.com/CVE-2026-0560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0560
- OSV: https://osv.dev/vulnerability/CVE-2026-0560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0560/
Summaries are generated and may contain mistakes; the official description above is the record.
