{"answers":{"affected":"2 open source packages ship an affected version, including gemini-mcp-tool.","exploited":"There is no known exploitation of CVE-2026-0755 in the wild and no public exploit code.","fix":"Upgrade gemini-mcp-tool to 1.1.6 or later.","what":"CVE-2026-0755 is a critical command injection vulnerability in gemini-mcp-tool, published on 23 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-0755 and fix it if it is affected.\n\nWhat it is: CVE-2026-0755 is a critical command injection vulnerability in gemini-mcp-tool, published on 23 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-0755 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gemini-mcp-tool (npm): affected from 1.1.2; fixed in 1.1.6\n- gemini-mcp-tool (npm): affected from 1.1.2; fixed in 1.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-0755/ (Markdown: https://insights.sbomify.com/CVE-2026-0755/index.md)","id":"CVE-2026-0755","markdown":"https://insights.sbomify.com/CVE-2026-0755/index.md","name":"CVE-2026-0755","record":{"aliases":["GHSA-4h5r-5jm8-jxjm"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Gemini MCP Tool","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via command injection in the execAsync method of the gemini-mcp-tool library without authentication.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"zdi","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"gemini-mcp-tool execAsync Command Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of gemini-mcp-tool. Authentication is not required to exploit this vulnerability.\n\nThe specific flaw exists within the implementation of the execAsync method. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-27783.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"gemini-mcp-tool execAsync Command Injection Remote Code Execution Vulnerability","id":"CVE-2026-0755","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"github-kanban-mcp-server execAsync Command Injection Remote Code Execution Vulnerability","id":"CVE-2026-0756"},"packages":[{"ecosystem":"npm","fixed":["1.1.6"],"introduced":["1.1.2"],"last_affected":[],"package":"gemini-mcp-tool","purl":null,"source":"GHSA-4h5r-5jm8-jxjm"},{"ecosystem":"npm","fixed":["1.1.6"],"introduced":["1.1.2"],"last_affected":[],"package":"gemini-mcp-tool","purl":"pkg:npm/gemini-mcp-tool","source":"GHSA-4h5r-5jm8-jxjm"}],"prev":{"headline":"SIP Service Providers – Possible Impersonation of Poly Voice Device","id":"CVE-2026-0754"},"products":["gemini-mcp-tool"],"published":"2026-01-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-23","vendors":["Gemini MCP Tool"]},"summary":"Remote attackers can execute arbitrary code via command injection in the execAsync method of the gemini-mcp-tool library without authentication.","url":"https://insights.sbomify.com/CVE-2026-0755/"}