# CVE-2026-0755: gemini-mcp-tool execAsync Command Injection Remote Code Execution Vulnerability

> Remote attackers can execute arbitrary code via command injection in the execAsync method of the gemini-mcp-tool library without authentication.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2026
- **Updated:** 23 Jan 2026
- **Also known as:** GHSA-4h5r-5jm8-jxjm

## What is CVE-2026-0755?

CVE-2026-0755 is a critical command injection vulnerability in gemini-mcp-tool, published on 23 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

gemini-mcp-tool execAsync Command Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of gemini-mcp-tool. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the implementation of the execAsync method. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-27783.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-0755?

2 open source packages ship an affected version, including gemini-mcp-tool.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gemini-mcp-tool` | npm | From 1.1.2 | 1.1.6 |
| `gemini-mcp-tool` | npm | From 1.1.2 | 1.1.6 |

## How do I fix CVE-2026-0755?

Upgrade gemini-mcp-tool to 1.1.6 or later.

## Is CVE-2026-0755 being exploited?

There is no known exploitation of CVE-2026-0755 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0755 and fix it if it is affected.

What it is: CVE-2026-0755 is a critical command injection vulnerability in gemini-mcp-tool, published on 23 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-0755 in the wild and no public exploit code.

Affected packages and fixed versions:
- gemini-mcp-tool (npm): affected from 1.1.2; fixed in 1.1.6
- gemini-mcp-tool (npm): affected from 1.1.2; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0755/ (Markdown: https://insights.sbomify.com/CVE-2026-0755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0755
- OSV: https://osv.dev/vulnerability/CVE-2026-0755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0755/
Summaries are generated and may contain mistakes; the official description above is the record.
