{"answers":{"affected":"2 open source packages ship an affected version, including @questdb/web-console.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0824 exists.","fix":"Upgrade @questdb/web-console to 1.1.10 or later.","what":"CVE-2026-0824 is a medium-severity cross-site scripting vulnerability in questdb ui, published on 10 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-0824 and fix it if it is affected.\n\nWhat it is: CVE-2026-0824 is a medium-severity cross-site scripting vulnerability in questdb ui, published on 10 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0824 exists.\n\nAffected packages and fixed versions:\n- @questdb/web-console (npm): affected all versions; fixed in 1.1.10\n- @questdb/web-console (npm): affected all versions; fixed in 1.1.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-0824/ (Markdown: https://insights.sbomify.com/CVE-2026-0824/index.md)","id":"CVE-2026-0824","markdown":"https://insights.sbomify.com/CVE-2026-0824/index.md","name":"CVE-2026-0824","record":{"aliases":["GHSA-xf94-h87h-g9wr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"QuestDB UI","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts in the QuestDB Web Console, potentially compromising user sessions and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A security flaw has been discovered in questdb ui up to 1.11.9. Impacted is an unknown function of the component Web Console. The manipulation results in cross site scripting. The attack can be executed remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 1.1.10 is recommended to address this issue. The patch is identified as b42fd9f18476d844ae181a10a249e003dafb823d. You should upgrade the affected component. The vendor confirmed early that the fix \"is going to be released as a part of QuestDB 9.3.0\" as well.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"questdb ui Web Console cross site scripting","id":"CVE-2026-0824","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":9,"next":{"headline":"Missing authorization in Database for Contact Form 7, WPforms, Elementor forms","id":"CVE-2026-0825"},"packages":[{"ecosystem":"npm","fixed":["1.1.10"],"introduced":["0"],"last_affected":[],"package":"@questdb/web-console","purl":null,"source":"GHSA-xf94-h87h-g9wr"},{"ecosystem":"npm","fixed":["1.1.10"],"introduced":["0"],"last_affected":[],"package":"@questdb/web-console","purl":"pkg:npm/%40questdb/web-console","source":"GHSA-xf94-h87h-g9wr"}],"prev":{"headline":"** REJECT ** DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2026-0823"},"products":["ui"],"published":"2026-01-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-23","vendors":["questdb"]},"summary":"Remote attackers can execute arbitrary scripts in the QuestDB Web Console, potentially compromising user sessions and data.","url":"https://insights.sbomify.com/CVE-2026-0824/"}