# CVE-2026-0824: questdb ui Web Console cross site scripting

> Remote attackers can execute arbitrary scripts in the QuestDB Web Console, potentially compromising user sessions and data.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 23 Feb 2026
- **Also known as:** GHSA-xf94-h87h-g9wr

## What is CVE-2026-0824?

CVE-2026-0824 is a medium-severity cross-site scripting vulnerability in questdb ui, published on 10 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A security flaw has been discovered in questdb ui up to 1.11.9. Impacted is an unknown function of the component Web Console. The manipulation results in cross site scripting. The attack can be executed remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 1.1.10 is recommended to address this issue. The patch is identified as b42fd9f18476d844ae181a10a249e003dafb823d. You should upgrade the affected component. The vendor confirmed early that the fix "is going to be released as a part of QuestDB 9.3.0" as well.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-0824?

2 open source packages ship an affected version, including @questdb/web-console.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@questdb/web-console` | npm | All versions | 1.1.10 |
| `@questdb/web-console` | npm | All versions | 1.1.10 |

## How do I fix CVE-2026-0824?

Upgrade @questdb/web-console to 1.1.10 or later.

## Is CVE-2026-0824 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0824 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0824 and fix it if it is affected.

What it is: CVE-2026-0824 is a medium-severity cross-site scripting vulnerability in questdb ui, published on 10 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0824 exists.

Affected packages and fixed versions:
- @questdb/web-console (npm): affected all versions; fixed in 1.1.10
- @questdb/web-console (npm): affected all versions; fixed in 1.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0824/ (Markdown: https://insights.sbomify.com/CVE-2026-0824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0824
- OSV: https://osv.dev/vulnerability/CVE-2026-0824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0824/
Summaries are generated and may contain mistakes; the official description above is the record.
