# CVE-2026-0847: Path Traversal in nltk/nltk

> Attackers can read arbitrary files on the server via path traversal in NLTK CorpusReader classes, exposing sensitive data like keys and tokens.

- **Severity:** High 8.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 16 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-0847, ECHO-e33c-86f9-2eb1, GHSA-68j8-pq59-fqgm, MGASA-2026-0057, PYSEC-2026-98, openSUSE-SU-2026:10304-1

## What is CVE-2026-0847?

CVE-2026-0847 is a high-severity path traversal vulnerability in nltk/nltk, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in NLTK versions up to and including 3.9.2 allows arbitrary file read via path traversal in multiple CorpusReader classes, including WordListCorpusReader, TaggedCorpusReader, and BracketParseCorpusReader. These classes fail to properly sanitize or validate file paths, enabling attackers to traverse directories and access sensitive files on the server. This issue is particularly critical in scenarios where user-controlled file inputs are processed, such as in machine learning APIs, chatbots, or NLP pipelines. Exploitation of this vulnerability can lead to unauthorized access to sensitive files, including system files, SSH private keys, and API tokens, and may potentially escalate to remote code execution when combined with other vulnerabilities.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-0847?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions to 3.9.2 | None |
| `nltk` | PyPI | All versions to 3.9.2 | None |
| `nltk` | PyPI | All versions | 3.9.3 |
| `python-nltk` | openSUSE:Tumbleweed | All versions | 3.9.3-1.1 |

Products: Nltk Nltk.

## How do I fix CVE-2026-0847?

Upgrade nltk to 3.9.3 or later.

## Is CVE-2026-0847 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0847 exists.

Public exploit code:

- A vulnerability in NLTK versions up to and including 3.9.2 allows arbitrary file read via path traversal in multiple CorpusReader classes, including WordListCorpusReader, TaggedCorpusReader, and BracketParseCorpusReader. (github_poc): https://github.com/HyperPS/CVE-2026-0847

## Other vulnerabilities in nltk/nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0847 and fix it if it is affected.

What it is: CVE-2026-0847 is a high-severity path traversal vulnerability in nltk/nltk, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0847 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions up to 3.9.2; no fix listed
- nltk (PyPI): affected all versions up to 3.9.2; no fix listed
- nltk (PyPI): affected all versions; fixed in 3.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0847/ (Markdown: https://insights.sbomify.com/CVE-2026-0847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0847
- OSV: https://osv.dev/vulnerability/CVE-2026-0847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0847/
Summaries are generated and may contain mistakes; the official description above is the record.
