# CVE-2026-0848: Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading

> Attackers can execute arbitrary code by supplying malicious JAR files to the NLTK StanfordSegmenter module, affecting Python NLP applications.

- **Severity:** Critical 10.0 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 6 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-0848, GHSA-v2w2-xcg6-53wj, PYSEC-2026-99

## What is CVE-2026-0848?

CVE-2026-0848 is a critical code injection vulnerability in nltk/nltk, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLTK versions <=3.9.2 are vulnerable to arbitrary code execution due to improper input validation in the StanfordSegmenter module. The module dynamically loads external Java .jar files without verification or sandboxing. An attacker can supply or replace the JAR file, enabling the execution of arbitrary Java bytecode at import time. This vulnerability can be exploited through methods such as model poisoning, MITM attacks, or dependency poisoning, leading to remote code execution. The issue arises from the direct execution of the JAR file via subprocess with unvalidated classpath input, allowing malicious classes to execute when loaded by the JVM.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-0848?

1 open source package ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.9.3 |

Products: Nltk Nltk.

## How do I fix CVE-2026-0848?

Upgrade nltk to 3.9.3 or later.

## Is CVE-2026-0848 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0848 exists.

Public exploit code:

- nltk.tokenize.StanfordSegmenter dynamically loads external Java .jar files without verification or sandboxing. If an attacker can supply or replace the JAR (e.g., a poisoned model download, MITM package swap, or dependency poisoning), arbitrary Java bytecode executes at import time. (github_poc): https://github.com/HyperPS/CVE-2026-0848
- PoC de CVE-2026-0848: validacion de entrada indebida en NLTK que permite ejecucion de codigo via StanfordSegmenter. (github_poc): https://github.com/fevar54/CVE-2026-0848-PoC-Improper-Input-Validation
- Scanner de CVE-2026-0848: detecta instalaciones de NLTK 3.9.2 o inferiores vulnerables. Reportes JSON/HTML/CSV. (github_poc): https://github.com/fevar54/CVE-2026-0848-Scanner---Herramienta-de-Detecci-n

## Other vulnerabilities in nltk/nltk

- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)
- [CVE-2026-79674](https://insights.sbomify.com/CVE-2026-79674/): NLTK 3.10.2 Path Traversal via corpus-reader constructors (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0848 and fix it if it is affected.

What it is: CVE-2026-0848 is a critical code injection vulnerability in nltk/nltk, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-0848 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0848/ (Markdown: https://insights.sbomify.com/CVE-2026-0848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0848
- OSV: https://osv.dev/vulnerability/CVE-2026-0848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0848/
Summaries are generated and may contain mistakes; the official description above is the record.
