# CVE-2026-0858: PlantUML is vulnerable to Stored XSS due to insufficient sanitization of interactive attributes in GraphViz diagrams

> Attackers can inject malicious JavaScript into PlantUML diagrams, leading to arbitrary script execution in applications rendering the SVG output.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jan 2026
- **Updated:** 16 Jan 2026
- **Also known as:** DEBIAN-CVE-2026-0858, GHSA-hrvf-g648-rf3m, UBUNTU-CVE-2026-0858

## What is CVE-2026-0858?

CVE-2026-0858 is a medium-severity cross-site scripting vulnerability in net.sourceforge.plantuml:plantuml, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of the package net.sourceforge.plantuml:plantuml before 1.2026.0 are vulnerable to Stored XSS due to insufficient sanitization of interactive attributes in GraphViz diagrams. As a result, a crafted PlantUML diagram can inject malicious JavaScript into generated SVG output, leading to arbitrary script execution in the context of applications that render the SVG.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-0858?

2 open source packages ship an affected version, including net.sourceforge.plantuml:plantuml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.sourceforge.plantuml:plantuml` | Maven | All versions | 1.2026.0 |
| `net.sourceforge.plantuml:plantuml` | Maven | All versions | 1.2026.0 |

Products: Plantuml Plantuml.

## How do I fix CVE-2026-0858?

Upgrade net.sourceforge.plantuml:plantuml to 1.2026.0 or later.

## Is CVE-2026-0858 being exploited?

There is no known exploitation of CVE-2026-0858 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0858 and fix it if it is affected.

What it is: CVE-2026-0858 is a medium-severity cross-site scripting vulnerability in net.sourceforge.plantuml:plantuml, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-0858 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.sourceforge.plantuml:plantuml (Maven): affected all versions; fixed in 1.2026.0
- net.sourceforge.plantuml:plantuml (Maven): affected all versions; fixed in 1.2026.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0858/ (Markdown: https://insights.sbomify.com/CVE-2026-0858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0858
- OSV: https://osv.dev/vulnerability/CVE-2026-0858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0858/
Summaries are generated and may contain mistakes; the official description above is the record.
