{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-0867 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-0867 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-0867 is a medium-severity cross-site scripting vulnerability in catchthemes Essential Widgets, published on 5 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-0867 and fix it if it is affected.\n\nWhat it is: CVE-2026-0867 is a medium-severity cross-site scripting vulnerability in catchthemes Essential Widgets, published on 5 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-0867 in the wild and no public exploit code.\n\nAffected product: catchthemes Essential Widgets. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-0867/ (Markdown: https://insights.sbomify.com/CVE-2026-0867/index.md)","id":"CVE-2026-0867","markdown":"https://insights.sbomify.com/CVE-2026-0867/index.md","name":"CVE-2026-0867","record":{"aliases":["GHSA-g2r7-xxg5-8j7m"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated attackers with contributor access can inject arbitrary scripts via shortcodes, leading to script execution on victim pages.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Essential Widgets plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's ew-author, ew-archive, ew-category, ew-page, and ew-menu shortcodes in all versions up to, and including, 3.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in version 3.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Essential Widgets \u003c= 3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Shortcodes","id":"CVE-2026-0867","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"EMC Scheduling Manager \u003c= 4.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via calendly Shortcode","id":"CVE-2026-0868"},"packages":[],"prev":{"headline":"After the publication of the PoC by the researcher and further analysis, we have determined that this issue does not constitute a valid vulnerability.","id":"CVE-2026-0866"},"products":["Essential Widgets"],"published":"2026-02-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["catchthemes"]},"summary":"Authenticated attackers with contributor access can inject arbitrary scripts via shortcodes, leading to script execution on victim pages.","url":"https://insights.sbomify.com/CVE-2026-0867/"}