{"answers":{"affected":"4 open source packages ship an affected version, including wrangler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-0933 in the wild and no public exploit code.","fix":"Upgrade wrangler to a fixed version for your release line: 3.114.17 or 4.59.1.","what":"CVE-2026-0933 is a high-severity command injection vulnerability in Cloudflare Wrangler, published on 20 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-0933 and fix it if it is affected.\n\nWhat it is: CVE-2026-0933 is a high-severity command injection vulnerability in Cloudflare Wrangler, published on 20 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-0933 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wrangler (npm): affected from 2.0.15; fixed in 3.114.17\n- wrangler (npm): affected from 2.0.15; fixed in 3.114.17\n- wrangler (npm): affected from 4.0.0; fixed in 4.59.1\n- wrangler (npm): affected from 4.0.0; fixed in 4.59.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-0933/ (Markdown: https://insights.sbomify.com/CVE-2026-0933/index.md)","id":"CVE-2026-0933","markdown":"https://insights.sbomify.com/CVE-2026-0933/index.md","name":"CVE-2026-0933","record":{"aliases":["GHSA-36p8-mvp6-cv38"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloudflare Wrangler CLI","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands via the --commit-hash parameter in Wrangler pages deploy, primarily affecting CI/CD pipelines.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"cloudflare","cpe":[{"product":"wrangler","vendor":"cloudflare"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"SummaryA command injection vulnerability (CWE-78) has been found to exist in the `wrangler pages deploy` command. The issue occurs because the `--commit-hash` parameter is passed directly to a shell command without proper validation or sanitization, allowing an attacker with control of `--commit-hash` to execute arbitrary commands on the system running Wrangler.\n\nRoot causeThe commitHash variable, derived from user input via the --commit-hash CLI argument, is interpolated directly into a shell command using template literals (e.g.,  execSync(`git show -s --format=%B ${commitHash}`)). Shell metacharacters are interpreted by the shell, enabling command execution.\n\nImpactThis vulnerability is generally hard to exploit, as it requires --commit-hash to be attacker controlled. The vulnerability primarily affects CI/CD environments where `wrangler pages deploy` is used in automated pipelines and the \n\n--commit-hash parameter is populated from external, potentially untrusted sources. An attacker could exploit this to:\n\n  *  Run any shell command.\n  *  Exfiltrate environment variables.\n  *  Compromise the CI runner to install backdoors or modify build artifacts.\n\nCredits Disclosed responsibly by kny4hacker.\n\nMitigation\n  *  Wrangler v4 users are requested to upgrade to Wrangler v4.59.1 or higher.\n  *  Wrangler v3 users are requested to upgrade to Wrangler v3.114.17 or higher.\n  *  Users on Wrangler v2 (EOL) should upgrade to a supported major version.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OS Command Injection in `wrangler pages deploy`","id":"CVE-2026-0933","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"Incorrect Authorization in GitLab","id":"CVE-2026-0934"},"packages":[{"ecosystem":"npm","fixed":["3.114.17"],"introduced":["2.0.15"],"last_affected":[],"package":"wrangler","purl":null,"source":"GHSA-36p8-mvp6-cv38"},{"ecosystem":"npm","fixed":["3.114.17"],"introduced":["2.0.15"],"last_affected":[],"package":"wrangler","purl":"pkg:npm/wrangler","source":"GHSA-36p8-mvp6-cv38"},{"ecosystem":"npm","fixed":["4.59.1"],"introduced":["4.0.0"],"last_affected":[],"package":"wrangler","purl":null,"source":"GHSA-36p8-mvp6-cv38"},{"ecosystem":"npm","fixed":["4.59.1"],"introduced":["4.0.0"],"last_affected":[],"package":"wrangler","purl":"pkg:npm/wrangler","source":"GHSA-36p8-mvp6-cv38"}],"prev":{"headline":"Server-side request forgery in M-Files Server","id":"CVE-2026-0932"},"products":["Wrangler"],"published":"2026-01-20","related":[{"cvss_score":8.5,"headline":"Arbitrary remote code execution within wrangler dev Workers sandbox","id":"CVE-2023-7080","kev_date_added":null,"published":"2023-12-29"},{"cvss_score":6.4,"headline":"Arbitrary remote file read in Wrangler dev server","id":"CVE-2023-7079","kev_date_added":null,"published":"2023-12-29"},{"cvss_score":5.7,"headline":"Directory traversal vulnerability in Cloudflare Wrangler","id":"CVE-2023-3348","kev_date_added":null,"published":"2023-08-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-23","vendors":["Cloudflare"]},"summary":"Attackers can execute arbitrary commands via the --commit-hash parameter in Wrangler pages deploy, primarily affecting CI/CD pipelines.","url":"https://insights.sbomify.com/CVE-2026-0933/"}