CVE-2026-0934 Incorrect Authorization in GitLab

Low 3.8 Published Updated

Authenticated users with custom roles can bypass CI/CD visibility restrictions to view, create, or delete protected environment configurations.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-0934?

CVE-2026-0934 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 25 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.9 before 18.11.6, 19.0 before 19.0.3, and 19.1 before 19.1.1 that under certain conditions could have allowed an authenticated user with custom role permissions to view, create, or delete protected environment configurations despite CI/CD visibility being disabled for the project.

Weakness: CWE-863

Which versions are affected by CVE-2026-0934?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.9.018.11.6, 19.0.3, 19.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-0934?

Upgrade gitlab to a fixed version for your release line: 18.11.6, 19.0.3 or 19.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-0934 being exploited?

There is no known exploitation of CVE-2026-0934 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-0934, GHSA-394r-q6wg-v263.

Is CVE-2026-0934 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free