CVE-2026-0958 Interpretation Conflict in GitLab

High 7.5 Published Updated

An unauthenticated attacker can cause denial of service in GitLab by exhausting memory or CPU through bypassed JSON validation limits.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-0958?

CVE-2026-0958 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 11 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.4 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that could have allowed an unauthenticated user to cause denial of service through memory or CPU exhaustion by bypassing JSON validation middleware limits.

Weakness: CWE-436

Which versions are affected by CVE-2026-0958?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.4.018.6.6, 18.7.4, 18.8.4

Products include Gitlab Gitlab.

How do I fix CVE-2026-0958?

Upgrade gitlab to a fixed version for your release line: 18.6.6, 18.7.4 or 18.8.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-0958 being exploited?

There is no known exploitation of CVE-2026-0958 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-0958, GHSA-9fx3-39vw-q4x9, UBUNTU-CVE-2026-0958.

Is CVE-2026-0958 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free