CVE-2026-0969 Arbitrary code execution in React server-side rendering of untrusted MDX content

High 8.8 Published Updated

Attackers can execute arbitrary code by providing malicious MDX content to the next-mdx-remote library during server-side rendering.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-0969?

CVE-2026-0969 is a high-severity code injection vulnerability in HashiCorp Shared library, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.

Weakness: CWE-94

Which versions are affected by CVE-2026-0969?

2 open source packages ship an affected version, including next-mdx-remote.

PackageAffectedFixed in
next-mdx-remote npmFrom 4.3.06.0.0
next-mdx-remote npmFrom 4.3.06.0.0

How do I fix CVE-2026-0969?

Upgrade next-mdx-remote to 6.0.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-0969 being exploited?

There is no known exploitation of CVE-2026-0969 in the wild and no public exploit code.

Sources

Also known as GHSA-g4xw-jxrg-5f6m.

Is CVE-2026-0969 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free