# CVE-2026-0969: Arbitrary code execution in React server-side rendering of untrusted MDX content

> Attackers can execute arbitrary code by providing malicious MDX content to the next-mdx-remote library during server-side rendering.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 17 Apr 2026
- **Also known as:** GHSA-g4xw-jxrg-5f6m

## What is CVE-2026-0969?

CVE-2026-0969 is a high-severity code injection vulnerability in HashiCorp Shared library, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The serialize function used to compile MDX in next-mdx-remote is vulnerable to arbitrary code execution due to insufficient sanitization of MDX content. This vulnerability, CVE-2026-0969, is fixed in next-mdx-remote 6.0.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-0969?

2 open source packages ship an affected version, including next-mdx-remote.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next-mdx-remote` | npm | From 4.3.0 | 6.0.0 |
| `next-mdx-remote` | npm | From 4.3.0 | 6.0.0 |

## How do I fix CVE-2026-0969?

Upgrade next-mdx-remote to 6.0.0 or later.

## Is CVE-2026-0969 being exploited?

There is no known exploitation of CVE-2026-0969 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0969 and fix it if it is affected.

What it is: CVE-2026-0969 is a high-severity code injection vulnerability in HashiCorp Shared library, published on 12 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-0969 in the wild and no public exploit code.

Affected packages and fixed versions:
- next-mdx-remote (npm): affected from 4.3.0; fixed in 6.0.0
- next-mdx-remote (npm): affected from 4.3.0; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0969/ (Markdown: https://insights.sbomify.com/CVE-2026-0969/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0969
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0969
- OSV: https://osv.dev/vulnerability/CVE-2026-0969

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0969/
Summaries are generated and may contain mistakes; the official description above is the record.
