# CVE-2026-0980: Rubyipmi: red hat satellite: remote code execution in rubyipmi via malicious bmc username

> An authenticated attacker with host permissions can achieve remote code execution on Red Hat Satellite by injecting commands via a malicious BMC username.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2026
- **Updated:** 26 Mar 2026
- **Also known as:** GHSA-hfcp-477w-3wjw

## What is CVE-2026-0980?

CVE-2026-0980 is a high-severity command injection vulnerability in Redhat Satellite, published on 27 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in rubyipmi, a gem used in the Baseboard Management Controller (BMC) component of Red Hat Satellite. An authenticated attacker with host creation or update permissions could exploit this vulnerability by crafting a malicious username for the BMC interface. This could lead to remote code execution (RCE) on the system.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-0980?

2 open source packages ship an affected version, including rubyipmi. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rubyipmi` | RubyGems | All versions | 0.13.0 |
| `rubyipmi` | RubyGems | All versions | 0.13.0 |

Products: Logicminds Rubyipmi, Redhat Satellite.

## How do I fix CVE-2026-0980?

Upgrade rubyipmi to 0.13.0 or later.

## Is CVE-2026-0980 being exploited?

There is no known exploitation of CVE-2026-0980 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0980 and fix it if it is affected.

What it is: CVE-2026-0980 is a high-severity command injection vulnerability in Redhat Satellite, published on 27 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-0980 in the wild and no public exploit code.

Affected packages and fixed versions:
- rubyipmi (RubyGems): affected all versions; fixed in 0.13.0
- rubyipmi (RubyGems): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0980/ (Markdown: https://insights.sbomify.com/CVE-2026-0980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0980
- OSV: https://osv.dev/vulnerability/CVE-2026-0980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0980/
Summaries are generated and may contain mistakes; the official description above is the record.
