{"answers":{"affected":"3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-zoom. It affects 2 products.","exploited":"There is no known exploitation of CVE-2026-0997 in the wild and no public exploit code.","fix":"Upgrade github.com/mattermost/mattermost-plugin-zoom to 1.11.0 or later.","what":"CVE-2026-0997 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-0997 and fix it if it is affected.\n\nWhat it is: CVE-2026-0997 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-0997 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/mattermost/mattermost-plugin-zoom (Go): affected all versions; fixed in 1.11.0\n- github.com/mattermost/mattermost-plugin-zoom (Go): affected all versions; fixed in 1.11.0\n- github.com/mattermost/mattermost-plugin-zoom (Go): affected all versions; fixed in 1.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-0997/ (Markdown: https://insights.sbomify.com/CVE-2026-0997/index.md)","id":"CVE-2026-0997","markdown":"https://insights.sbomify.com/CVE-2026-0997/index.md","name":"CVE-2026-0997","record":{"aliases":["GHSA-2phx-frhf-xr55","GO-2026-4519"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost Zoom Plugin","requires_auth":"low_privilege","summary":"Any logged-in user can modify Zoom meeting restrictions for arbitrary channels due to missing authorization checks in the Mattermost Zoom Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mattermost","cpe":[{"product":"mattermost_server","vendor":"mattermost"},{"product":"zoom","vendor":"mattermost"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Mattermost versions 11.1.x \u003c= 11.1.2, 10.11.x \u003c= 10.11.9, 11.2.x \u003c= 11.2.1 and Mattermost Plugin Zoom versions \u003c=1.11.0 fail to validate the authenticated user when processing {{/plugins/zoom/api/v1/channel-preference}}, which allows any logged-in user to change Zoom meeting restrictions for arbitrary channels via crafted API requests.. Mattermost Advisory ID: MMSA-2025-00558","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mattermost Zoom Plugin channel preference API lacks authorization checks","id":"CVE-2026-0997","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":"mattermost:mattermost_server","products":["mattermost:mattermost_server"],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Mattermost Zoom Plugin allows unauthorized meeting creation and post modification via insufficient API access controls","id":"CVE-2026-0998"},"packages":[{"ecosystem":"Go","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-zoom","purl":null,"source":"GHSA-2phx-frhf-xr55"},{"ecosystem":"Go","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-zoom","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-zoom","source":"GHSA-2phx-frhf-xr55"},{"ecosystem":"Go","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-zoom","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-zoom","source":"GO-2026-4519"}],"prev":{"headline":"Fluent Forms \u003c= 6.1.14 - Authenticated (Subscriber+) Stored Cross-Site Scripting via AI Form Builder Module","id":"CVE-2026-0996"},"products":["Mattermost"],"published":"2026-02-16","related":[{"cvss_score":9.9,"headline":"Account takeover on OAuth/OpenID-enabled servers","id":"CVE-2025-12419","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Account Takeover via Code Exchange Endpoint","id":"CVE-2025-12421","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Path Traversal Leading to RCE by Any Authenticated Mattermost User","id":"CVE-2025-4981","kev_date_added":null,"published":"2025-06-20"},{"cvss_score":9.9,"headline":"Arbitrary file read via block duplication in Mattermost Boards","id":"CVE-2025-20051","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.9,"headline":"Arbitrary file read in Mattermost Boards via import \u0026 export board archive","id":"CVE-2025-25279","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.8,"headline":"Mattermost Server: Insufficient Password-Reset Link Invalidation","id":"CVE-2016-11074","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":9.8,"headline":"Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials","id":"CVE-2017-18885","kev_date_added":null,"published":"2020-06-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-17","vendors":["Mattermost"]},"summary":"Any logged-in user can modify Zoom meeting restrictions for arbitrary channels due to missing authorization checks in the Mattermost Zoom Plugin.","url":"https://insights.sbomify.com/CVE-2026-0997/"}