# CVE-2026-0998: Mattermost Zoom Plugin allows unauthorized meeting creation and post modification via insufficient API access controls

> Attackers can create unauthorized Zoom meetings and modify arbitrary posts by bypassing user identity and ownership checks in the API.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2026
- **Updated:** 17 Feb 2026
- **Also known as:** GHSA-w65c-fvp5-fvc5, GO-2026-4525

## What is CVE-2026-0998?

CVE-2026-0998 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.1.x <= 11.1.2, 10.11.x <= 10.11.9, 11.2.x <= 11.2.1 and Mattermost Plugin Zoom versions <=1.11.0 fail to validate user identity and post ownership in the {{/api/v1/askPMI}} endpoint which allows unauthorized users to start Zoom meetings as any user and overwrite arbitrary posts via direct API calls with manipulated user IDs and post data.. Mattermost Advisory ID: MMSA-2025-00534

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-0998?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-zoom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-plugin-zoom` | Go | All versions | 1.12.0 |
| `github.com/mattermost/mattermost-plugin-zoom` | Go | All versions | 1.12.0 |
| `github.com/mattermost/mattermost-plugin-zoom` | Go | All versions | 1.12.0 |

Products: Mattermost Mattermost Server, Mattermost Zoom.

## How do I fix CVE-2026-0998?

Upgrade github.com/mattermost/mattermost-plugin-zoom to 1.12.0 or later.

## Is CVE-2026-0998 being exploited?

There is no known exploitation of CVE-2026-0998 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-0998 and fix it if it is affected.

What it is: CVE-2026-0998 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-0998 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-plugin-zoom (Go): affected all versions; fixed in 1.12.0
- github.com/mattermost/mattermost-plugin-zoom (Go): affected all versions; fixed in 1.12.0
- github.com/mattermost/mattermost-plugin-zoom (Go): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-0998/ (Markdown: https://insights.sbomify.com/CVE-2026-0998/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-0998
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-0998
- OSV: https://osv.dev/vulnerability/CVE-2026-0998

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-0998/
Summaries are generated and may contain mistakes; the official description above is the record.
