# CVE-2026-100347: kin-openapi: Unauthenticated panic (DoS) in openapi3filter legacy router via non-canonical/unsupported HTTP method on a static path

> Unauthenticated attackers can cause a denial of service by sending non-canonical HTTP methods to static paths, triggering a panic in the kin-openapi library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** CLEANSTART-2026-RK72601, DEBIAN-CVE-2026-100347, ECHO-6d09-b18b-72ae, GHSA-fh4f-47mf-f2gj, MINI-2c38-px6r-749c, MINI-2qx7-3mvx-3329, MINI-389c-cm76-7jgh, MINI-3p38-47r6-h3q4, MINI-3x44-9vmh-hvmh, MINI-4jp7-rrpm-95f8, MINI-5h4w-q3m7-qq8g, MINI-68j3-658w-757x, MINI-6c73-72h5-87w7, MINI-99wh-54mp-274x, MINI-9qfm-rfg4-c574, MINI-9w83-r3qx-w943, MINI-f8v5-fj2q-3f5q, MINI-f9hw-3pv6-5pv8, MINI-fv49-cr44-m2pw, MINI-fwqw-jp24-7x8v, MINI-fx5r-m2gw-496h, MINI-g8qg-q8jw-pphm, MINI-gxw7-qgf6-256c, MINI-jq8j-84w2-vhqp, MINI-m2g3-wrrv-5cfc, MINI-m5qh-779h-j32c, MINI-p24h-2gpr-h7f3, MINI-q22j-h62m-7c64, MINI-q52f-rfjh-cmpg, MINI-q9cw-24p3-2hv8, MINI-qhq8-qjgj-632x, MINI-r9f2-3vx4-4rh7, MINI-rcg4-xc23-whx3, MINI-rmm7-8jp9-jg62, MINI-w9v2-jw64-hrj9, MINI-wmmv-wqhg-9vxm, UBUNTU-CVE-2026-100347

## What is CVE-2026-100347?

CVE-2026-100347 is a medium-severity denial of service vulnerability in getkin kin-openapi, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

kin-openapi is a Go project for handling OpenAPI files. Prior to 0.145.0, openapi3filter.ValidationHandler uses the routers/legacy router, which passes an unsupported or non-canonical HTTP method for an existing static path to openapi3.PathItem.GetOperation. The default branch of GetOperation panics before authentication runs, so an unauthenticated remote client can repeatedly send methods such as PROPFIND or lowercase get to abort connections and generate stack-trace log growth. The specific panic requires an exact static path; a concrete path matched only by a templated route does not reach the same sink. This issue is fixed in version 0.145.0.

Weakness: CWE-248 (Uncaught Exception), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-100347?

2 open source packages ship an affected version, including github.com/getkin/kin-openapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.145.0 |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.145.0 |

## How do I fix CVE-2026-100347?

Upgrade github.com/getkin/kin-openapi to 0.145.0 or later.

## Is CVE-2026-100347 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100347 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100347 and fix it if it is affected.

What it is: CVE-2026-100347 is a medium-severity denial of service vulnerability in getkin kin-openapi, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100347 exists.

Affected packages and fixed versions:
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.145.0
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.145.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100347/ (Markdown: https://insights.sbomify.com/CVE-2026-100347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100347
- OSV: https://osv.dev/vulnerability/CVE-2026-100347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100347/
Summaries are generated and may contain mistakes; the official description above is the record.
