# CVE-2026-100368: CliInvoke.Specializations: Command injection in PowerShell and Cmd shell wrappers

> Attackers can execute arbitrary OS commands via untrusted input in PowerShell and Cmd wrappers due to improper quoting, requiring library upgrades.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-wrvw-254r-wpmv

## What is CVE-2026-100368?

CVE-2026-100368 is a high-severity command injection vulnerability in alastairlundy CliInvoke.Specializations, published on 25 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

CliInvoke is a .NET library for invoking command-line programs, and its `CliInvoke.Specializations` packages provide specialized wrappers for shells such as PowerShell and Windows Command Prompt. `CliInvoke.Specializations` versions 2.2.0 through 2.8.4, 2.9.0 through 2.9.3, 2.10.0 through 2.10.4, 3.0.0-alpha.1 through 3.0.0-alpha.4, and 3.0.0-alpha.8 through 3.0.0-alpha.10, as well as `AlastairLundy.CliInvoke.Specializations` versions 1.0.0-rc.1 through 1.6.1.1, contain an OS command injection vulnerability in their PowerShell and Cmd wrappers. The wrappers pass a caller-controlled target and arguments to `pwsh -Command` or `cmd /c` using a single `ProcessStartInfo.Arguments` string, allowing a double quote in untrusted input to break operating-system-level quoting and cause the shell to execute an additional command with the host process's privileges. The vulnerability is patched in `CliInvoke.Specializations` versions 2.8.5, 2.9.4, 2.10.5, and 3.0.0-beta.1, and in `AlastairLundy.CliInvoke.Specializations` version 2.0.2. No complete workaround is available; users unable to upgrade should reject or remove double quotes from target paths and arguments, additionally reject shell metacharacters in versions 2.2.0 through 2.9.2 and 3.0.0-alpha.1 through 3.0.0-alpha.4, or bypass the PowerShell and Cmd wrappers and invoke target processes directly when handling untrusted input.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-100368?

12 open source packages ship an affected version, including AlastairLundy.CliInvoke.Specializations and CliInvoke.Specializations.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `AlastairLundy.CliInvoke.Specializations` | NuGet | From 1.0.0-rc.1 | 2.0.2 |
| `AlastairLundy.CliInvoke.Specializations` | NuGet | From 1.0.0-rc.1 | 2.0.2 |
| `CliInvoke.Specializations` | NuGet | From 2.10.0 | 2.10.5 |
| `CliInvoke.Specializations` | NuGet | From 2.10.0 | 2.10.5 |
| `CliInvoke.Specializations` | NuGet | From 2.2.0 | 2.8.5 |
| `CliInvoke.Specializations` | NuGet | From 2.2.0 | 2.8.5 |
| `CliInvoke.Specializations` | NuGet | From 2.9.0 | 2.9.4 |
| `CliInvoke.Specializations` | NuGet | From 2.9.0 | 2.9.4 |
| `CliInvoke.Specializations` | NuGet | From 3.0.0-alpha.1 | 3.0.0-beta.1 |
| `CliInvoke.Specializations` | NuGet | From 3.0.0-alpha.1 | 3.0.0-beta.1 |
| `CliInvoke.Specializations` | NuGet | From 3.0.0-alpha.8 | 3.0.0-beta.1 |
| `CliInvoke.Specializations` | NuGet | From 3.0.0-alpha.8 | 3.0.0-beta.1 |

## How do I fix CVE-2026-100368?

Upgrade AlastairLundy.CliInvoke.Specializations to 2.0.2 or later.

## Is CVE-2026-100368 being exploited?

There is no known exploitation of CVE-2026-100368 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100368 and fix it if it is affected.

What it is: CVE-2026-100368 is a high-severity command injection vulnerability in alastairlundy CliInvoke.Specializations, published on 25 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100368 in the wild and no public exploit code.

Affected packages and fixed versions:
- AlastairLundy.CliInvoke.Specializations (NuGet): affected from 1.0.0-rc.1; fixed in 2.0.2
- AlastairLundy.CliInvoke.Specializations (NuGet): affected from 1.0.0-rc.1; fixed in 2.0.2
- CliInvoke.Specializations (NuGet): affected from 2.10.0; fixed in 2.10.5
- CliInvoke.Specializations (NuGet): affected from 2.10.0; fixed in 2.10.5
- CliInvoke.Specializations (NuGet): affected from 2.2.0; fixed in 2.8.5
- CliInvoke.Specializations (NuGet): affected from 2.2.0; fixed in 2.8.5
- CliInvoke.Specializations (NuGet): affected from 2.9.0; fixed in 2.9.4
- CliInvoke.Specializations (NuGet): affected from 2.9.0; fixed in 2.9.4
- CliInvoke.Specializations (NuGet): affected from 3.0.0-alpha.1; fixed in 3.0.0-beta.1
- CliInvoke.Specializations (NuGet): affected from 3.0.0-alpha.1; fixed in 3.0.0-beta.1
- CliInvoke.Specializations (NuGet): affected from 3.0.0-alpha.8; fixed in 3.0.0-beta.1
- CliInvoke.Specializations (NuGet): affected from 3.0.0-alpha.8; fixed in 3.0.0-beta.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100368/ (Markdown: https://insights.sbomify.com/CVE-2026-100368/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100368
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100368
- OSV: https://osv.dev/vulnerability/CVE-2026-100368

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100368/
Summaries are generated and may contain mistakes; the official description above is the record.
