CVE-2026-100369 CliInvoke: Argument Injection in Extensibility Runner Factory
Attackers can inject arguments via double quotes in targets or arguments, potentially leading to arbitrary command execution in applications using this .NET library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-100369?
CVE-2026-100369 is a high-severity command injection vulnerability in AlastairLundy.CliInvoke, published on 25 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
CliInvoke and its formerly named `AlastairLundy.CliInvoke` package are .NET libraries for invoking command-line programs and wrapping executable processes. `CliInvoke` versions 2.0.0 through 2.8.4, 2.9.0 through 2.9.3, 2.10.0 through 2.10.4, and 3.0.0-alpha.1 through 3.0.0-beta.1, as well as `AlastairLundy.CliInvoke` versions 2.0.0-alpha.1 through 2.0.0, contain an argument-injection vulnerability in `RunnerProcessFactory` on the 2.x line and `RunnerConfigurationFactory` on the 3.x line. These factories combine runner arguments, a caller-controlled target, and caller-controlled arguments into one `ProcessStartInfo.Arguments` string, allowing a double quote in the target or an argument to terminate an operating-system-level quoted region and inject unintended elements into the runner’s argument vector, potentially resulting in arbitrary command execution when a shell runner is used. The vulnerability is patched in `CliInvoke` versions 2.8.5, 2.9.4, 2.10.5, and 3.0.0-beta.2, and in `AlastairLundy.CliInvoke` version 2.0.2. No complete workaround is available; users unable to upgrade can partially mitigate the issue by removing double quotes from targets and arguments, additionally removing shell metacharacters when using shell runners, or bypassing the vulnerable factory and constructing a `ProcessConfiguration` with an explicit `ArgumentList`.
Weakness: CWE-88
Which versions are affected by CVE-2026-100369?
10 open source packages ship an affected version, including AlastairLundy.CliInvoke and CliInvoke.
| Package | Affected | Fixed in |
|---|---|---|
AlastairLundy.CliInvoke NuGet | From 2.0.0-alpha.1 | 2.0.2 |
AlastairLundy.CliInvoke NuGet | From 2.0.0-alpha.1 | 2.0.2 |
CliInvoke NuGet | From 2.0.0 | 2.8.5 |
CliInvoke NuGet | From 2.0.0 | 2.8.5 |
CliInvoke NuGet | From 2.10.0 | 2.10.5 |
CliInvoke NuGet | From 2.10.0 | 2.10.5 |
4 more packages
CliInvoke NuGet | From 2.9.0 | 2.9.4 |
CliInvoke NuGet | From 2.9.0 | 2.9.4 |
CliInvoke NuGet | From 3.0.0-alpha.1 | 3.0.0-beta.2 |
CliInvoke NuGet | From 3.0.0-alpha.1 | 3.0.0-beta.2 |
How do I fix CVE-2026-100369?
Upgrade AlastairLundy.CliInvoke to 2.0.2 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-100369 being exploited?
There is no known exploitation of CVE-2026-100369 in the wild and no public exploit code.
Sources
Also known as GHSA-j73w-8hfr-4gc9.