# CVE-2026-100535: OpenClaw before 2026.8.1 Privilege Escalation via Session Memory

> Attackers can escalate privileges by persisting malicious instructions in session memory that are later executed by a background agent with broader capabilities.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-62qm-6fjj-6g23, GHSA-q46f-hgrw-cqvr, MINI-h7m2-7hxm-j935

## What is CVE-2026-100535?

CVE-2026-100535 is a high-severity vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw (npm package 'openclaw') versions >= 2026.4.5 and < 2026.8.1 can lose the originating requester's restrictions and untrusted provenance when session-derived text is persisted to session memory. In deployments where session-memory capture and dreaming are enabled, a restricted external sender whose messages are admitted with limited tools can persist instructions that are later supplied to an unattended background (dreaming) agent holding broader file and command capabilities, allowing actions beyond the authority of the original turn and affecting files, commands, or services available to that agent. Exploitation requires the content to be captured, selected for later processing, and followed by the model. The issue is fixed in 2026.8.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-100535?


## How do I fix CVE-2026-100535?

Upgrade to a fixed version.

## Is CVE-2026-100535 being exploited?

There is no known exploitation of CVE-2026-100535 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100535 and fix it if it is affected.

What it is: CVE-2026-100535 is a high-severity vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100535 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100535/ (Markdown: https://insights.sbomify.com/CVE-2026-100535/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100535
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100535
- OSV: https://osv.dev/vulnerability/CVE-2026-100535

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100535/
Summaries are generated and may contain mistakes; the official description above is the record.
