# CVE-2026-100541: OpenClaw Matrix before 2026.8.1 Authorization Bypass via Case Folding

> Attackers can bypass authorization checks by exploiting case-folding flaws in user ID normalization, inheriting privileged permissions from other accounts.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-4793-q4pp-q755, GHSA-hgv5-f2r3-6v9r

## What is CVE-2026-100541?

CVE-2026-100541 is a high-severity authentication bypass vulnerability in openclaw matrix, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw's Matrix integration (npm package @openclaw/matrix) versions >= 2026.2.2 and < 2026.8.1 lowercase complete Matrix user IDs — including historical localparts and the case-sensitive server-name portion — when deriving the OpenClaw authorization identity. As a result, distinct authenticated Matrix accounts can normalize to the same authorization identity. A Matrix participant controlling a colliding account identifier (a protocol-valid identifier that differs from the configured one only by characters OpenClaw case/Unicode folds; display-name matching is not required) can inherit allowlist, owner-command, exec-approval, or plugin-approval authority configured for another account. The issue is fixed in 2026.8.1.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-100541?


## How do I fix CVE-2026-100541?

No fix has been published for CVE-2026-100541 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-100541 being exploited?

There is no known exploitation of CVE-2026-100541 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100541 and fix it if it is affected.

What it is: CVE-2026-100541 is a high-severity authentication bypass vulnerability in openclaw matrix, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100541 in the wild and no public exploit code.

Affected product: openclaw matrix. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100541/ (Markdown: https://insights.sbomify.com/CVE-2026-100541/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100541
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100541
- OSV: https://osv.dev/vulnerability/CVE-2026-100541

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100541/
Summaries are generated and may contain mistakes; the official description above is the record.
