# CVE-2026-100542: OpenClaw before 2026.8.1 Extraction Limit Bypass via tar.bz2

> Attackers can bypass extraction limits in OpenClaw via crafted tar.bz2 archives, causing disk or inode exhaustion when operators install malicious skills.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-5966-v5hf-7x84, GHSA-6xpv-wwr5-265h, MINI-p48j-7qwm-r62f

## What is CVE-2026-100542?

CVE-2026-100542 is a low-severity denial of service vulnerability in OpenClaw, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenClaw (npm package 'openclaw') versions >= 2026.5.28 and < 2026.8.1 mishandle archive listings in the tar.bz2 skill installer: bounded command-output suffixes were treated as complete listings of the archive. A crafted .tar.bz2/.tbz2 skill archive can push prohibited entries out of both retained listings so that entry-count and size checks pass, and the archive is then extracted in full. If an operator approves installation of such a malicious or compromised skill archive, over-limit files or entry counts are persisted in the skill tools directory, consuming disk space or inodes. The issue bypasses OpenClaw's extraction budgets but does not by itself execute archive contents. Fixed in 2026.8.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-100542?


## How do I fix CVE-2026-100542?

Upgrade to a fixed version.

## Is CVE-2026-100542 being exploited?

There is no known exploitation of CVE-2026-100542 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100542 and fix it if it is affected.

What it is: CVE-2026-100542 is a low-severity denial of service vulnerability in OpenClaw, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-100542 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100542/ (Markdown: https://insights.sbomify.com/CVE-2026-100542/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100542
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100542
- OSV: https://osv.dev/vulnerability/CVE-2026-100542

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100542/
Summaries are generated and may contain mistakes; the official description above is the record.
