# CVE-2026-100544: openclaw voice-call before 2026.8.1 Authorization Bypass

> Remote callers can bypass owner-only tool filtering to execute commands and access data if inbound calling is enabled.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-3w3q-3hpq-fv5m, GHSA-rrxp-5mx8-mvhh, MINI-gfjf-rqg4-gp9c

## What is CVE-2026-100544?

CVE-2026-100544 is a high-severity missing authorization vulnerability in openclaw voice-call, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

openclaw's @openclaw/voice-call package before 2026.8.1 launches the configured agent for classic inbound voice calls without propagating the caller's identity or non-owner status. As a result, owner-only tool filtering can fail open and expose the agent's normal tool authority to a remote caller. A caller who is admitted by the configured inbound-call policy (open, pairing, or allowlist) on a deployment with inbound calling enabled can therefore drive tools intended for the trusted owner, potentially reading data, modifying files, executing commands, or controlling connected services depending on the agent's configuration. The issue is fixed in 2026.8.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-100544?


## How do I fix CVE-2026-100544?

Upgrade to a fixed version.

## Is CVE-2026-100544 being exploited?

There is no known exploitation of CVE-2026-100544 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100544 and fix it if it is affected.

What it is: CVE-2026-100544 is a high-severity missing authorization vulnerability in openclaw voice-call, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100544 in the wild and no public exploit code.

Affected product: openclaw voice-call. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100544/ (Markdown: https://insights.sbomify.com/CVE-2026-100544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100544
- OSV: https://osv.dev/vulnerability/CVE-2026-100544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100544/
Summaries are generated and may contain mistakes; the official description above is the record.
