# CVE-2026-100545: OpenClaw before 2026.8.1 Policy Bypass via Session Filename Generation


- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-5fwv-rrvp-8xvr, GHSA-hf7w-6cmf-hc98, MINI-hjrp-p46r-2j92

## What is CVE-2026-100545?

CVE-2026-100545 is a medium-severity vulnerability in OpenClaw, published on 26 Sep 2026. 

### Official description

OpenClaw (npm package `openclaw`) before 2026.8.1 incorrectly enforces sender tool policies during session-memory filename generation. In affected versions, filename generation created an embedded helper that retained tools which the originating sender's policy had removed. When session-memory filename generation was enabled for an agent reachable by lower-trust senders, model-mediated instructions could cause the helper to invoke tools outside that sender's effective policy; the demonstrated impact was the creation of persistent scheduled work. Exploitability depends on the model acting on the injected instruction and on which tools the helper exposes. The issue is fixed in 2026.8.1; as a workaround, disable session-memory filename generation for agents reachable by lower-trust senders.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-100545?


## How do I fix CVE-2026-100545?

Upgrade to a fixed version.

## Is CVE-2026-100545 being exploited?

There is no known exploitation of CVE-2026-100545 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100545 and fix it if it is affected.

What it is: CVE-2026-100545 is a medium-severity vulnerability in OpenClaw, published on 26 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-100545 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100545/ (Markdown: https://insights.sbomify.com/CVE-2026-100545/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100545
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100545
- OSV: https://osv.dev/vulnerability/CVE-2026-100545

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100545/
Summaries are generated and may contain mistakes; the official description above is the record.
