# CVE-2026-100547: OpenClaw before 2026.8.1 Authentication Bypass via File URL

> An attacker controlling an ACP peer can bypass path restrictions to read local files outside the session directory in OpenClaw.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-356g-m7rx-7pm3, GHSA-3fp8-r6r3-vjcc, MINI-575f-fghc-9vxv

## What is CVE-2026-100547?

CVE-2026-100547 is a medium-severity path traversal vulnerability in OpenClaw, published on 26 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenClaw is a coding agent distributed as the npm package `openclaw`. In affected versions (2026.7.1 through 2026.7.2), alternate but valid `file:` URL spellings supplied over the Agent Client Protocol (ACP) were treated as relative paths and were incorrectly classified as reads scoped to the session working directory. When an operator connected `openclaw acp client` to an untrusted or compromised ACP peer, that peer could request a read of a file outside the session working directory without the approval prompt normally required for that path, resulting in disclosure of local file contents. The demonstrated impact is limited to file confidentiality; mutating and command-capable tool classes are not affected. This issue is fixed in OpenClaw 2026.8.1.

Weakness: CWE-180 (Incorrect Behavior Order: Validate Before Canonicalize)

## Which versions are affected by CVE-2026-100547?


## How do I fix CVE-2026-100547?

Upgrade to a fixed version.

## Is CVE-2026-100547 being exploited?

There is no known exploitation of CVE-2026-100547 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100547 and fix it if it is affected.

What it is: CVE-2026-100547 is a medium-severity path traversal vulnerability in OpenClaw, published on 26 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-100547 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100547/ (Markdown: https://insights.sbomify.com/CVE-2026-100547/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100547
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100547
- OSV: https://osv.dev/vulnerability/CVE-2026-100547

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100547/
Summaries are generated and may contain mistakes; the official description above is the record.
