CVE-2026-100548 OpenClaw before 2026.8.1 Credential Exposure via Embedding Fallback

Medium 6.0 Published Updated

OpenClaw library exposes primary API keys to fallback providers during embedding failures, requiring configuration changes or upgrades to prevent credential leakage.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-100548?

CVE-2026-100548 is a medium-severity vulnerability in OpenClaw, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

OpenClaw (npm package 'openclaw') versions >= 2026.3.28 and < 2026.8.1 contain a credential exposure issue in memory embedding failover. When remote embedding fallback is configured and the primary embedding provider fails, the request can be sent to a different fallback provider while still reusing the primary provider's configured API key, causing that credential to be transmitted as a bearer token to an unintended vendor. The practical impact depends on the configured providers, whether failover occurs, and the privileges attached to the primary provider key. The issue is fixed in 2026.8.1; as a workaround, disable cross-provider embedding fallback or configure each provider with separate, narrowly scoped credentials.

Weakness: CWE-200

Which versions are affected by CVE-2026-100548?

How do I fix CVE-2026-100548?

Upgrade to a fixed version.

Is CVE-2026-100548 being exploited?

There is no known exploitation of CVE-2026-100548 in the wild and no public exploit code.

Sources

Also known as GHSA-66hm-hxq3-5pfh, GHSA-9ffh-hv34-6589, MINI-c4hg-2hfv-pm89.

Is CVE-2026-100548 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free