# CVE-2026-100552: OpenClaw before 2026.8.1 Policy Bypass via Native Tools

> OpenClaw fails to enforce per-chat tool policies for Codex runtime tools, allowing attackers to bypass allowlists and access native command and file tools.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-cwwp-j7pm-h7wg, GHSA-wwcw-jfpp-gpxw, MINI-55xj-r2j7-wr7q

## What is CVE-2026-100552?

CVE-2026-100552 is a high-severity vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw (npm package 'openclaw') before 2026.8.1 does not correctly enforce per-chat tool policies for Codex app-server runtime tools. A conversation-level tools.allow rule filtered OpenClaw tools but did not restrict the shell, process, file, and patch tools owned by the Codex runtime. When a lower-trust conversation was assigned to a Codex runtime and restricted with a per-chat tool allowlist, a participant able to trigger that agent could still reach native command and file tools, bypassing the configured allowlist. The practical impact depends on the runtime's host permissions and sandbox configuration. The issue is fixed in 2026.8.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-100552?


## How do I fix CVE-2026-100552?

Upgrade to a fixed version.

## Is CVE-2026-100552 being exploited?

There is no known exploitation of CVE-2026-100552 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100552 and fix it if it is affected.

What it is: CVE-2026-100552 is a high-severity vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100552 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100552/ (Markdown: https://insights.sbomify.com/CVE-2026-100552/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100552
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100552
- OSV: https://osv.dev/vulnerability/CVE-2026-100552

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100552/
Summaries are generated and may contain mistakes; the official description above is the record.
