{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-10056 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-10056 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-10056 is a high-severity vulnerability in Network Optix Nx Witness VMS, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-10056 and fix it if it is affected.\n\nWhat it is: CVE-2026-10056 is a high-severity vulnerability in Network Optix Nx Witness VMS, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-10056 in the wild and no public exploit code.\n\nAffected product: Network Optix Nx Witness VMS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-10056/ (Markdown: https://insights.sbomify.com/CVE-2026-10056/index.md)","id":"CVE-2026-10056","markdown":"https://insights.sbomify.com/CVE-2026-10056/index.md","name":"CVE-2026-10056","record":{"aliases":["GHSA-r863-5pgm-c8g4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Video Management System","requires_auth":"none","summary":"An unauthenticated attacker can steal session tokens via a malicious webpage due to CORS misconfiguration, leading to administrator account takeover.","user_interaction":"required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"NX","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-942","name":"Permissive Cross-domain Security Policy with Untrusted Domains"}],"description":"CORS misconfiguration in the REST API of Network Optix Nx Witness VMS before version 6.1.2, when running in the default Standard security mode, on Linux and Windows allows an unauthenticated remote attacker to steal the session token of an authenticated user and perform Administrator Account Takeover via a malicious cross-origin web page visited by the victim. The High security mode is not affected.Workaround:\n\nFor existing installations running in Standard security mode, set Access-Control-Allow-Credentials to false via the REST API: PATCH /rest/v2/system/settings with body {\"supportedOrigins\": \"null\"}. Alternatively, select High security level during initial setup.\n\nSolution:\n\nUpdate to Nx Witness VMS version 6.1.2 or later, in which Access-Control-Allow-Credentials is set to false in the default Standard security configuration.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"CORS misconfiguration in Nx Witness VMS allows session token exfiltration via cross-origin request","id":"CVE-2026-10056","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"misconfiguration","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"ITP Technology｜ITS Intelligent SCADA System - Stored Cross-Site Scripting","id":"CVE-2026-10057"},"packages":[],"prev":{"headline":"Server-side request forgery in Eclipse Theia","id":"CVE-2026-10055"},"products":["Nx Witness VMS"],"published":"2026-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-29","vendors":["Network Optix"]},"summary":"An unauthenticated attacker can steal session tokens via a malicious webpage due to CORS misconfiguration, leading to administrator account takeover.","url":"https://insights.sbomify.com/CVE-2026-10056/"}