# CVE-2026-10056: CORS misconfiguration in Nx Witness VMS allows session token exfiltration via cross-origin request

> An unauthenticated attacker can steal session tokens via a malicious webpage due to CORS misconfiguration, leading to administrator account takeover.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-r863-5pgm-c8g4

## What is CVE-2026-10056?

CVE-2026-10056 is a high-severity vulnerability in Network Optix Nx Witness VMS, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CORS misconfiguration in the REST API of Network Optix Nx Witness VMS before version 6.1.2, when running in the default Standard security mode, on Linux and Windows allows an unauthenticated remote attacker to steal the session token of an authenticated user and perform Administrator Account Takeover via a malicious cross-origin web page visited by the victim. The High security mode is not affected.Workaround:

For existing installations running in Standard security mode, set Access-Control-Allow-Credentials to false via the REST API: PATCH /rest/v2/system/settings with body {"supportedOrigins": "null"}. Alternatively, select High security level during initial setup.

Solution:

Update to Nx Witness VMS version 6.1.2 or later, in which Access-Control-Allow-Credentials is set to false in the default Standard security configuration.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2026-10056?


## How do I fix CVE-2026-10056?

No fix has been published for CVE-2026-10056 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-10056 being exploited?

There is no known exploitation of CVE-2026-10056 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10056 and fix it if it is affected.

What it is: CVE-2026-10056 is a high-severity vulnerability in Network Optix Nx Witness VMS, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-10056 in the wild and no public exploit code.

Affected product: Network Optix Nx Witness VMS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10056/ (Markdown: https://insights.sbomify.com/CVE-2026-10056/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10056
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10056
- OSV: https://osv.dev/vulnerability/CVE-2026-10056

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10056/
Summaries are generated and may contain mistakes; the official description above is the record.
