# CVE-2026-100561: OpenClaw before 2026.8.1 Authentication Bypass via Exec Wrapper

> Attackers can bypass exec approval policies to execute arbitrary commands with host privileges if a wrapper was previously approved.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-cqqj-25gc-9q2f, GHSA-ghpx-6xwq-2w4w, MINI-5x82-45mf-mrf7

## What is CVE-2026-100561?

CVE-2026-100561 is a high-severity authentication bypass vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenClaw (npm package 'openclaw') versions >= 2026.3.22 and < 2026.8.1 contain an approval-bypass flaw in the exec approval policy: the policy could trust a command-running wrapper without inspecting the command carried in its arguments. After an operator allowlisted or permanently approved a benign wrapper invocation, a later agent turn could substitute an arbitrary inner command and execute it with the OpenClaw process's host privileges without a further approval prompt. Exploitation requires the relevant wrapper to resolve on the host and a prior operator decision allowing that wrapper. Transparent shell carriers and opaque utilities such as process monitors, tracers, namespace tools, and proxy wrappers were affected through related trust-resolution gaps. Fixed in 2026.8.1.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-100561?


## How do I fix CVE-2026-100561?

Upgrade to a fixed version.

## Is CVE-2026-100561 being exploited?

There is no known exploitation of CVE-2026-100561 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100561 and fix it if it is affected.

What it is: CVE-2026-100561 is a high-severity authentication bypass vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-100561 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100561/ (Markdown: https://insights.sbomify.com/CVE-2026-100561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100561
- OSV: https://osv.dev/vulnerability/CVE-2026-100561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100561/
Summaries are generated and may contain mistakes; the official description above is the record.
