# CVE-2026-100569: OpenClaw before 2026.8.1 Credential Exposure via Endpoint Override

> An attacker can steal Azure Speech keys by manipulating workspace environment variables, requiring specific Azure configuration and operator interaction.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-5cqq-r556-6vv9, GHSA-pfrw-r5vr-89hw, MINI-gqxh-3gxc-p6q4

## What is CVE-2026-100569?

CVE-2026-100569 is a medium-severity vulnerability in OpenClaw, published on 26 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenClaw is an npm-distributed application. In versions >= 2026.4.25 and < 2026.8.1, the workspace environment-variable filter did not block variables ending in `_ENDPOINT`, so an untrusted workspace `.env` file could set AZURE_SPEECH_ENDPOINT. Azure Speech preferred that value over the configured region, so when a synthesis or voice-list request was made, the attacker-selected endpoint received the operator's Azure Speech key in the request header, allowing the key to be reused against the operator's Azure Speech resource. Exploitation requires an operator to start OpenClaw in attacker-controlled workspace content with Azure Speech configured with a key and region and no trusted endpoint override set. The issue is fixed in 2026.8.1.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2026-100569?


## How do I fix CVE-2026-100569?

Upgrade to a fixed version.

## Is CVE-2026-100569 being exploited?

There is no known exploitation of CVE-2026-100569 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100569 and fix it if it is affected.

What it is: CVE-2026-100569 is a medium-severity vulnerability in OpenClaw, published on 26 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-100569 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100569/ (Markdown: https://insights.sbomify.com/CVE-2026-100569/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100569
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100569
- OSV: https://osv.dev/vulnerability/CVE-2026-100569

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100569/
Summaries are generated and may contain mistakes; the official description above is the record.
