{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-100570 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-100570 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-100570 and fix it if it is affected.\n\nWhat it is: CVE-2026-100570 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-100570 in the wild and no public exploit code.\n\nAffected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-100570/ (Markdown: https://insights.sbomify.com/CVE-2026-100570/index.md)","id":"CVE-2026-100570","markdown":"https://insights.sbomify.com/CVE-2026-100570/index.md","name":"CVE-2026-100570","record":{"aliases":["GHSA-5mrc-77hj-xjxv","GHSA-g53g-fv6q-g8f9","MINI-qq98-943w-p57f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"OpenClaw npm package","requires_auth":"none","summary":"An attacker can execute arbitrary code by manipulating environment variables in a workspace, leading to credential theft and file modification.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"OpenClaw (npm package 'openclaw') versions \u003e= 2026.3.28 and \u003c 2026.8.1 allow an untrusted workspace .env file to set the CLOUDSDK_PYTHON_ARGS environment variable. When an operator starts OpenClaw in attacker-controlled workspace content and then runs the Gmail setup flow, that value is inherited when gcloud is launched, and the gcloud launcher passes it as arguments to the trusted Python interpreter. A crafted CLOUDSDK_PYTHON_ARGS value can therefore cause Python to execute attacker-supplied code with the OpenClaw host user's permissions, allowing credentials to be read, files to be modified, or other processes to be started. This issue is fixed in version 2026.8.1; as a workaround, run Gmail setup only from trusted workspaces and clear inherited CLOUDSDK_* variables beforehand.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenClaw before 2026.8.1 Remote Code Execution via CLOUDSDK_PYTHON_ARGS","id":"CVE-2026-100570","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"OpenClaw before 2026.8.1 SMS Webhook Rate Limit Bypass","id":"CVE-2026-100571"},"packages":[],"prev":{"headline":"OpenClaw before 2026.8.1 Credential Exposure via Endpoint Override","id":"CVE-2026-100569"},"products":["OpenClaw"],"published":"2026-09-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["OpenClaw"]},"summary":"An attacker can execute arbitrary code by manipulating environment variables in a workspace, leading to credential theft and file modification.","url":"https://insights.sbomify.com/CVE-2026-100570/"}