# CVE-2026-100570: OpenClaw before 2026.8.1 Remote Code Execution via CLOUDSDK_PYTHON_ARGS

> An attacker can execute arbitrary code by manipulating environment variables in a workspace, leading to credential theft and file modification.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-5mrc-77hj-xjxv, GHSA-g53g-fv6q-g8f9, MINI-qq98-943w-p57f

## What is CVE-2026-100570?

CVE-2026-100570 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenClaw (npm package 'openclaw') versions >= 2026.3.28 and < 2026.8.1 allow an untrusted workspace .env file to set the CLOUDSDK_PYTHON_ARGS environment variable. When an operator starts OpenClaw in attacker-controlled workspace content and then runs the Gmail setup flow, that value is inherited when gcloud is launched, and the gcloud launcher passes it as arguments to the trusted Python interpreter. A crafted CLOUDSDK_PYTHON_ARGS value can therefore cause Python to execute attacker-supplied code with the OpenClaw host user's permissions, allowing credentials to be read, files to be modified, or other processes to be started. This issue is fixed in version 2026.8.1; as a workaround, run Gmail setup only from trusted workspaces and clear inherited CLOUDSDK_* variables beforehand.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-100570?


## How do I fix CVE-2026-100570?

Upgrade to a fixed version.

## Is CVE-2026-100570 being exploited?

There is no known exploitation of CVE-2026-100570 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100570 and fix it if it is affected.

What it is: CVE-2026-100570 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-100570 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100570/ (Markdown: https://insights.sbomify.com/CVE-2026-100570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100570
- OSV: https://osv.dev/vulnerability/CVE-2026-100570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100570/
Summaries are generated and may contain mistakes; the official description above is the record.
