# CVE-2026-100578: OpenClaw before 2026.7.1 Authorization Bypass via chat.send

> Non-owner users can invoke owner-only tools via chat.send in specific authentication modes, allowing unauthorized configuration changes and privilege escalation.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-9cj9-w25j-5478, GHSA-qw7m-h363-33qw, MINI-c7c4-c6c6-c86h

## What is CVE-2026-100578?

CVE-2026-100578 is a high-severity missing authorization vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw (npm package `openclaw`) before 2026.7.1 fails to restrict owner-only infrastructure tools exposed through the chat.send endpoint. In Gateway deployments using authentication modes that honor caller identity and narrower operator scopes, a write-scoped non-owner caller can start a chat turn whose tool inventory includes the `gateway` and `cron` tools, causing the agent to invoke owner-only configuration or scheduling operations, including persistent state changes. Practical impact depends on the tools selected by the model and the caller's ability to steer the turn. Shared-secret token and password callers are treated as fully trusted operators under OpenClaw's security model and are outside the scope of this issue. The issue is fixed in 2026.7.1; as a workaround, restrict chat.send to administrators in identity-bearing deployments and remove `gateway` and `cron` from affected agent tool policies.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-100578?


## How do I fix CVE-2026-100578?

Upgrade to a fixed version.

## Is CVE-2026-100578 being exploited?

There is no known exploitation of CVE-2026-100578 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100578 and fix it if it is affected.

What it is: CVE-2026-100578 is a high-severity missing authorization vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100578 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100578/ (Markdown: https://insights.sbomify.com/CVE-2026-100578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100578
- OSV: https://osv.dev/vulnerability/CVE-2026-100578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100578/
Summaries are generated and may contain mistakes; the official description above is the record.
