# CVE-2026-100579: OpenClaw before 2026.7.1 Authentication Bypass via Spoofed Requester

> Attackers can spoof requester identity to perform unauthorized channel actions in OpenClaw, requiring specific authentication modes.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-4wvr-f35r-f8w4, GHSA-6462-h5cx-j55p, MINI-q7f9-fcw7-fc89

## What is CVE-2026-100579?

CVE-2026-100579 is a high-severity authentication bypass vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw (npm package 'openclaw') before 2026.7.1 incorrectly trusts requester provenance in message.action. In identity-bearing Gateway deployments (authentication modes that honor caller identity and narrower operator scopes), a write-scoped caller can supply another sender's identifier to the channel authorization checks and invoke a channel action under that spoofed requester identity, reaching operations the channel adapter would have denied to the real caller. Practical impact depends on the enabled channel, the action, and the target account's permissions. Shared-secret token and password callers are full trusted operators under OpenClaw's security model and are out of scope. The issue is fixed in 2026.7.1; as a workaround, restrict message.action to administrators and disable sensitive channel actions that rely on requester identity.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-100579?


## How do I fix CVE-2026-100579?

Upgrade to a fixed version.

## Is CVE-2026-100579 being exploited?

There is no known exploitation of CVE-2026-100579 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100579 and fix it if it is affected.

What it is: CVE-2026-100579 is a high-severity authentication bypass vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100579 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100579/ (Markdown: https://insights.sbomify.com/CVE-2026-100579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100579
- OSV: https://osv.dev/vulnerability/CVE-2026-100579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100579/
Summaries are generated and may contain mistakes; the official description above is the record.
