# CVE-2026-100580: OpenClaw before 2026.7.1 Remote Code Execution via cron tool

> Attackers can execute arbitrary commands via a case-sensitivity flaw in the cron tool, leading to code execution and data access.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-8xxh-v4vc-qvm4, GHSA-mq3g-mch3-5cqc, MINI-xm9x-45v5-c955

## What is CVE-2026-100580?

CVE-2026-100580 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw (npm package 'openclaw') before 2026.7.1 improperly handles case sensitivity in the model-facing cron tool: a mixed-case payload kind can pass the agent-facing shell-execution guard and later normalize into a command job. An actor able to steer a tool-enabled agent can therefore create a persistent cron job that executes attacker-selected commands with the privileges of the OpenClaw process user, resulting in access to host files and credentials and impact to scheduled service availability. The issue is limited to cron jobs created or edited through the model-facing cron tool; direct CLI and authorized Gateway scheduling surfaces are trusted operator controls. Fixed in 2026.7.1.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-100580?


## How do I fix CVE-2026-100580?

Upgrade to a fixed version.

## Is CVE-2026-100580 being exploited?

There is no known exploitation of CVE-2026-100580 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100580 and fix it if it is affected.

What it is: CVE-2026-100580 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100580 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100580/ (Markdown: https://insights.sbomify.com/CVE-2026-100580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100580
- OSV: https://osv.dev/vulnerability/CVE-2026-100580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100580/
Summaries are generated and may contain mistakes; the official description above is the record.
