# CVE-2026-100588: OpenClaw before 2026.7.1 Authentication Bypass via node.invoke

> Attackers with write scope can bypass admin requirements to control browsers via node.invoke, allowing unauthorized page inspection and interaction.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 5 Oct 2026
- **Also known as:** GHSA-234j-jv97-3432, GHSA-jghr-xp78-995p, MINI-gvhw-356w-r537

## What is CVE-2026-100588?

CVE-2026-100588 is a high-severity missing authorization vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw (npm package 'openclaw') before 2026.7.1 does not enforce the administrator scope requirement on browser control when it is reached through the node.invoke method, although direct browser.request access requires administrator scope. In Gateway deployments that honor caller identity and narrower operator scopes, a write-scoped caller with access to a connected browser-capable node can inspect pages, navigate tabs, or interact with browser-visible applications without the configured admin requirement; practical impact depends on the browser profile and signed-in state. Shared-secret token and password callers are considered fully trusted operators under OpenClaw's security model and are not affected. The issue is fixed in 2026.7.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-100588?


## How do I fix CVE-2026-100588?

Upgrade to a fixed version.

## Is CVE-2026-100588 being exploited?

There is no known exploitation of CVE-2026-100588 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100588 and fix it if it is affected.

What it is: CVE-2026-100588 is a high-severity missing authorization vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100588 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100588/ (Markdown: https://insights.sbomify.com/CVE-2026-100588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100588
- OSV: https://osv.dev/vulnerability/CVE-2026-100588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100588/
Summaries are generated and may contain mistakes; the official description above is the record.
