CVE-2026-100599 OpenClaw 2026.5.1 before 2026.7.1 Remote Code Execution via googlemeet.chrome
Attackers can execute arbitrary commands on paired Chrome nodes via the Google Meet plugin, bypassing approval flows and compromising node security.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-100599?
CVE-2026-100599 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw versions 2026.5.1 through 2026.7.0 fail to apply the configured exec approval path to Google Meet node commands. The googlemeet.chrome command accepts caller-supplied audio command arrays and executes them on a paired node without going through the normal system.run approval flow. In deployments with the Google Meet plugin enabled, a paired Chrome node, and the googlemeet.chrome node command allowed, a tool-enabled agent able to invoke that command can execute attacker-selected processes on the paired node, impacting files, credentials, browser profiles, and availability on that node. The issue is fixed in 2026.7.1; as a workaround, remove googlemeet.chrome from allowed node commands or disable the Google Meet plugin.
Weakness: CWE-78
Which versions are affected by CVE-2026-100599?
How do I fix CVE-2026-100599?
Upgrade to a fixed version.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-100599 being exploited?
There is no known exploitation of CVE-2026-100599 in the wild and no public exploit code.
Sources
Also known as GHSA-224w-vfr9-h35c, GHSA-2vm8-mpc3-ch96, MINI-97rc-mpvw-76p5.