{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-100599 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-100599 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-100599 and fix it if it is affected.\n\nWhat it is: CVE-2026-100599 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-100599 in the wild and no public exploit code.\n\nAffected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-100599/ (Markdown: https://insights.sbomify.com/CVE-2026-100599/index.md)","id":"CVE-2026-100599","markdown":"https://insights.sbomify.com/CVE-2026-100599/index.md","name":"CVE-2026-100599","record":{"aliases":["GHSA-224w-vfr9-h35c","GHSA-2vm8-mpc3-ch96","MINI-97rc-mpvw-76p5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenClaw automation platform","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands on paired Chrome nodes via the Google Meet plugin, bypassing approval flows and compromising node security.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"OpenClaw versions 2026.5.1 through 2026.7.0 fail to apply the configured exec approval path to Google Meet node commands. The googlemeet.chrome command accepts caller-supplied audio command arrays and executes them on a paired node without going through the normal system.run approval flow. In deployments with the Google Meet plugin enabled, a paired Chrome node, and the googlemeet.chrome node command allowed, a tool-enabled agent able to invoke that command can execute attacker-selected processes on the paired node, impacting files, credentials, browser profiles, and availability on that node. The issue is fixed in 2026.7.1; as a workaround, remove googlemeet.chrome from allowed node commands or disable the Google Meet plugin.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenClaw 2026.5.1 before 2026.7.1 Remote Code Execution via googlemeet.chrome","id":"CVE-2026-100599","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"ClawHub before 8c2de6c506 Quota Exhaustion via Anonymous API","id":"CVE-2026-100600"},"packages":[],"prev":{"headline":"OpenClaw before 2026.7.1 Approval Binding Logic Error","id":"CVE-2026-100598"},"products":["OpenClaw"],"published":"2026-09-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-28","vendors":["OpenClaw"]},"summary":"Attackers can execute arbitrary commands on paired Chrome nodes via the Google Meet plugin, bypassing approval flows and compromising node security.","url":"https://insights.sbomify.com/CVE-2026-100599/"}