# CVE-2026-100599: OpenClaw 2026.5.1 before 2026.7.1 Remote Code Execution via googlemeet.chrome

> Attackers can execute arbitrary commands on paired Chrome nodes via the Google Meet plugin, bypassing approval flows and compromising node security.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-224w-vfr9-h35c, GHSA-2vm8-mpc3-ch96, MINI-97rc-mpvw-76p5

## What is CVE-2026-100599?

CVE-2026-100599 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw versions 2026.5.1 through 2026.7.0 fail to apply the configured exec approval path to Google Meet node commands. The googlemeet.chrome command accepts caller-supplied audio command arrays and executes them on a paired node without going through the normal system.run approval flow. In deployments with the Google Meet plugin enabled, a paired Chrome node, and the googlemeet.chrome node command allowed, a tool-enabled agent able to invoke that command can execute attacker-selected processes on the paired node, impacting files, credentials, browser profiles, and availability on that node. The issue is fixed in 2026.7.1; as a workaround, remove googlemeet.chrome from allowed node commands or disable the Google Meet plugin.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-100599?


## How do I fix CVE-2026-100599?

Upgrade to a fixed version.

## Is CVE-2026-100599 being exploited?

There is no known exploitation of CVE-2026-100599 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100599 and fix it if it is affected.

What it is: CVE-2026-100599 is a high-severity command injection vulnerability in OpenClaw, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100599 in the wild and no public exploit code.

Affected product: OpenClaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100599/ (Markdown: https://insights.sbomify.com/CVE-2026-100599/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100599
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100599
- OSV: https://osv.dev/vulnerability/CVE-2026-100599

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100599/
Summaries are generated and may contain mistakes; the official description above is the record.
