CVE-2026-100631 Parse Server 9.0.0 Unauthenticated Installation Deletion via Operator Injection

High 8.7 Published Updated

Unauthenticated attackers can inject query operators to delete all device registrations, disrupting push notifications in Parse Server deployments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-100631?

CVE-2026-100631 is a high-severity code injection vulnerability in parse-community parse-server, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Parse Server is an open source backend server. In versions prior to 8.6.90 and in versions from 9.0.0 prior to 9.10.1-alpha.9, the device token deduplication logic for installation records does not validate the type of client-supplied installation fields before using them to build database queries. An unauthenticated remote attacker who knows only the public application ID can submit non-string values in these fields to inject query operators, causing the deduplication cleanup — which runs with elevated privileges before class-level permissions are evaluated — to delete every device registration in the application or an attacker-chosen subset of them. No account, session token, master key, or user interaction is required. Deleted registrations cannot be recovered on the server, so push notifications cannot be delivered until every client re-registers. Any deployment that exposes the REST API to clients and uses push notifications is affected in its default configuration. Versions 8.6.90 and 9.10.1-alpha.9 fix the issue by rejecting non-string values with a client error and by scoping the deduplication cleanup to the calling application. No workaround other than upgrading is available.

Weakness: CWE-943

Which versions are affected by CVE-2026-100631?

1 open source package ship an affected version, including parse.

PackageAffectedFixed in
parse BitnamiAll versions8.6.90, 9.10.1

How do I fix CVE-2026-100631?

Upgrade parse to a fixed version for your release line: 8.6.90 or 9.10.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-100631 being exploited?

There is no known exploitation of CVE-2026-100631 in the wild and no public exploit code.

Sources

Also known as BIT-parse-2026-100631, GHSA-cc6h-c8m4-hgrx, GHSA-fq69-3pm5-2h3g.

Is CVE-2026-100631 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free