CVE-2026-100632 Parse Server 9.0.0 before 9.10.1 Protected Fields Disclosure via LiveQuery
Authenticated subscribers can bypass protected field restrictions in Parse Server LiveQuery, exposing sensitive data intended to be hidden from their role or user group.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-100632?
CVE-2026-100632 is a high-severity vulnerability in parse-community parse-server, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Parse Server is an open-source backend server. In versions >= 9.0.0 and < 9.10.1-alpha.8, and in versions < 8.6.89, LiveQuery evaluates the protectedFields class-level permission against an incompletely resolved caller identity: the subscriber's roles are not resolved, and when a subscription does not supply its own session token the event payload is redacted against an anonymous identity even though the read was authorized against the connected user. As a result, field masks defined for a role, for authenticated users, or for a specific user are not applied, so an authenticated subscriber can receive field values that the REST API correctly withholds and can use a masked field to filter or watch a subscription. Only classes with LiveQuery enabled that define protectedFields under a role:, authenticated, or per-user group are affected; masks under the public (*) group are applied correctly. The issue is fixed in 9.10.1-alpha.8 and 8.6.89. As a workaround, additionally define the affected field masks under the public (*) group, or disable LiveQuery for classes whose class-level permissions rely on role-scoped, authenticated, or per-user protectedFields groups.
Weakness: CWE-200
Which versions are affected by CVE-2026-100632?
1 open source package ship an affected version, including parse.
| Package | Affected | Fixed in |
|---|---|---|
parse Bitnami | All versions | 8.6.89, 9.10.1 |
How do I fix CVE-2026-100632?
Upgrade parse to a fixed version for your release line: 8.6.89 or 9.10.1.
Is CVE-2026-100632 being exploited?
There is no known exploitation of CVE-2026-100632 in the wild and no public exploit code.
Sources
Also known as BIT-parse-2026-100632, GHSA-9jpp-xhh6-75mf, GHSA-wwgr-gww6-xr82.