{"answers":{"affected":"1 open source package ship an affected version, including parse.","exploited":"There is no known exploitation of CVE-2026-100632 in the wild and no public exploit code.","fix":"Upgrade parse to a fixed version for your release line: 8.6.89 or 9.10.1.","what":"CVE-2026-100632 is a high-severity vulnerability in parse-community parse-server, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-100632 and fix it if it is affected.\n\nWhat it is: CVE-2026-100632 is a high-severity vulnerability in parse-community parse-server, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-100632 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse (Bitnami): affected all versions; fixed in 8.6.89, 9.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-100632/ (Markdown: https://insights.sbomify.com/CVE-2026-100632/index.md)","id":"CVE-2026-100632","markdown":"https://insights.sbomify.com/CVE-2026-100632/index.md","name":"CVE-2026-100632","record":{"aliases":["BIT-parse-2026-100632","GHSA-9jpp-xhh6-75mf","GHSA-wwgr-gww6-xr82"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Parse Server backend","requires_auth":"low_privilege","summary":"Authenticated subscribers can bypass protected field restrictions in Parse Server LiveQuery, exposing sensitive data intended to be hidden from their role or user group.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Parse Server is an open-source backend server. In versions \u003e= 9.0.0 and \u003c 9.10.1-alpha.8, and in versions \u003c 8.6.89, LiveQuery evaluates the protectedFields class-level permission against an incompletely resolved caller identity: the subscriber's roles are not resolved, and when a subscription does not supply its own session token the event payload is redacted against an anonymous identity even though the read was authorized against the connected user. As a result, field masks defined for a role, for authenticated users, or for a specific user are not applied, so an authenticated subscriber can receive field values that the REST API correctly withholds and can use a masked field to filter or watch a subscription. Only classes with LiveQuery enabled that define protectedFields under a role:, authenticated, or per-user group are affected; masks under the public (*) group are applied correctly. The issue is fixed in 9.10.1-alpha.8 and 8.6.89. As a workaround, additionally define the affected field masks under the public (*) group, or disable LiveQuery for classes whose class-level permissions rely on role-scoped, authenticated, or per-user protectedFields groups.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server 9.0.0 before 9.10.1 Protected Fields Disclosure via LiveQuery","id":"CVE-2026-100632","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"SiYuan 3.8.0 through 3.8.3 Path Traversal via MCP File Operations","id":"CVE-2026-100633"},"packages":[{"ecosystem":"Bitnami","fixed":["8.6.89","9.10.1"],"introduced":["0","9.0.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2026-100632"}],"prev":{"headline":"Parse Server 9.0.0 Unauthenticated Installation Deletion via Operator Injection","id":"CVE-2026-100631"},"products":["parse-server"],"published":"2026-09-26","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-28","vendors":["parse-community"]},"summary":"Authenticated subscribers can bypass protected field restrictions in Parse Server LiveQuery, exposing sensitive data intended to be hidden from their role or user group.","url":"https://insights.sbomify.com/CVE-2026-100632/"}