# CVE-2026-100650: vLLM before 0.29.0 Resource Exhaustion via Unbounded Media Materialization

> Remote attackers can exhaust server memory and bandwidth by sending large media payloads before size limits are enforced, causing denial of service.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-j8gm-f3cq-6c27, GHSA-p6g9-7v3x-m8mv, MINI-2fp9-g6p8-mv7g, MINI-jqmw-rwcg-8jf2, MINI-x36p-25px-ww53, PYSEC-2026-4184

## What is CVE-2026-100650?

CVE-2026-100650 is a high-severity denial of service vulnerability in Vllm Vllm, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM through 0.29.0 fetches and fully materializes remote or inline media before enforcing its documented media controls (the VLLM_MAX_AUDIO_CLIP_FILESIZE_MB compressed-audio size cap, default 25 MB, and the per-modality --limit-mm-per-prompt item limits). Across four ingress paths — the shared media-acquisition layer (HTTPConnection.get_bytes()/async_get_bytes()), the chat completions audio_url/base64 path, the batch speech runner, and the Rust frontend POST /tokenize route — the server reads the entire HTTP response body, base64-decodes the inline payload, or spawns one fetch/decode task per media part, and only then applies the limit (or, on some paths, never applies it). A remote attacker can therefore cause the API server or batch-runner process to allocate memory and consume outbound bandwidth proportional to an attacker-chosen body size or media item count before the request is rejected, resulting in pre-inference memory and bandwidth exhaustion (denial of service). The chat and batch surfaces require an API key when one is configured; the Rust frontend /tokenize route is unauthenticated by design. There is no code execution or data disclosure impact.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-100650?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.30.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-100650?

Upgrade vllm to 0.30.0 or later.

## Is CVE-2026-100650 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100650 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100650 and fix it if it is affected.

What it is: CVE-2026-100650 is a high-severity denial of service vulnerability in Vllm Vllm, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100650 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100650/ (Markdown: https://insights.sbomify.com/CVE-2026-100650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100650
- OSV: https://osv.dev/vulnerability/CVE-2026-100650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100650/
Summaries are generated and may contain mistakes; the official description above is the record.
