CVE-2026-100653 vLLM 0.22.1 before 0.28.0 Incomplete Artifact Pin Propagation

High 8.3 Published Updated

vLLM fails to propagate model revision pins for specific architectures, allowing upstream changes to alter behavior in pinned deployments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-100653?

CVE-2026-100653 is a high-severity vulnerability in Vllm Vllm, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models. In versions from 0.22.1 through 0.28.0, the operator-supplied model revision pin (--revision / --code-revision) is not propagated to several Hugging Face artifact loads for the FunAudioChat and Tarsier2 architectures: the WhisperFeatureExtractor and speech_tokenizer PreTrainedTokenizerFast loads in vllm/model_executor/models/funaudiochat.py and the Qwen2VLConfig.from_pretrained call used by Tarsier2ProcessingInfo in vllm/model_executor/models/qwen2_vl.py. As a result, deployments pinned to a reviewed revision still resolve these behavior-affecting processor, tokenizer, and config artifacts from the repository's default revision, so a later change to the upstream default branch can alter audio preprocessing, speech tokenizer behavior, or Tarsier2 configuration without any change to the operator's configured pin. This is a supply-chain integrity and reproducibility failure for pinned deployments; it is residual to the earlier fix tracked as GHSA-3ww4-5jv9-j5gm / CVE-2026-47155 and does not constitute remote code execution or a trust_remote_code=False bypass. The issue is fixed in version 0.28.0.

Weakness: CWE-348

Which versions are affected by CVE-2026-100653?

1 open source package ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.22.10.28.0

Products include Vllm Vllm.

How do I fix CVE-2026-100653?

Upgrade vllm to 0.28.0 or later.

Is CVE-2026-100653 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100653 exists.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-hhv2-872h-628q, GHSA-r3cf-2wgr-7xh9, MINI-mv84-q9fg-9xv8, MINI-rgg5-f64q-xh58, PYSEC-2026-4324.

Is CVE-2026-100653 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free