{"answers":{"affected":"1 open source package ship an affected version, including vllm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100653 exists.","fix":"Upgrade vllm to 0.28.0 or later.","what":"CVE-2026-100653 is a high-severity vulnerability in Vllm Vllm, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-100653 and fix it if it is affected.\n\nWhat it is: CVE-2026-100653 is a high-severity vulnerability in Vllm Vllm, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100653 exists.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.22.1; fixed in 0.28.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-100653/ (Markdown: https://insights.sbomify.com/CVE-2026-100653/index.md)","id":"CVE-2026-100653","markdown":"https://insights.sbomify.com/CVE-2026-100653/index.md","name":"CVE-2026-100653","record":{"aliases":["GHSA-hhv2-872h-628q","GHSA-r3cf-2wgr-7xh9","MINI-mv84-q9fg-9xv8","MINI-rgg5-f64q-xh58","PYSEC-2026-4324"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference engine","requires_auth":"none","summary":"vLLM fails to propagate model revision pins for specific architectures, allowing upstream changes to alter behavior in pinned deployments.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-348","name":"Use of Less Trusted Source"}],"description":"vLLM is an inference and serving engine for large language models. In versions from 0.22.1 through 0.28.0, the operator-supplied model revision pin (--revision / --code-revision) is not propagated to several Hugging Face artifact loads for the FunAudioChat and Tarsier2 architectures: the WhisperFeatureExtractor and speech_tokenizer PreTrainedTokenizerFast loads in vllm/model_executor/models/funaudiochat.py and the Qwen2VLConfig.from_pretrained call used by Tarsier2ProcessingInfo in vllm/model_executor/models/qwen2_vl.py. As a result, deployments pinned to a reviewed revision still resolve these behavior-affecting processor, tokenizer, and config artifacts from the repository's default revision, so a later change to the upstream default branch can alter audio preprocessing, speech tokenizer behavior, or Tarsier2 configuration without any change to the operator's configured pin. This is a supply-chain integrity and reproducibility failure for pinned deployments; it is residual to the earlier fix tracked as GHSA-3ww4-5jv9-j5gm / CVE-2026-47155 and does not constitute remote code execution or a trust_remote_code=False bypass. The issue is fixed in version 0.28.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vLLM 0.22.1 before 0.28.0 Incomplete Artifact Pin Propagation","id":"CVE-2026-100653","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"supply_chain","year":"2026"},"n_packages":1,"n_references":3,"next":{"headline":"vLLM before 0.29.0 Denial of Service via out-of-range stop_token_ids","id":"CVE-2026-100654"},"packages":[{"ecosystem":"PyPI","fixed":["0.28.0"],"introduced":["0.22.1"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-4324"}],"prev":{"headline":"vLLM 0.22.0 through 0.23.0 Denial of Service via stop_token_ids","id":"CVE-2026-100652"},"products":["vllm"],"published":"2026-09-26","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["vllm-project"]},"summary":"vLLM fails to propagate model revision pins for specific architectures, allowing upstream changes to alter behavior in pinned deployments.","url":"https://insights.sbomify.com/CVE-2026-100653/"}